标记的问题 [pip]

14
9 回复
完全卸载Django
我使用pip uninstall Django在我的机器上卸载了django。它说成功卸载了,而当我在python shell中看到django版本时,它仍然提供我安装的旧版本。 要从pytho...
问 5年前
144
10 回复
由于egg_info错误,无法通过pip安装
无论我尝试安装哪个软件包,都会收到此错误:  error: invalid command 'egg_info' ---------------------------------------- Cleaning up... Command p...
84
15 回复
在Windows上,pip install access被拒绝
我正在尝试在Windows上运行pip install mitmproxy,但我仍然拒绝访问,即使cmd和PowerShell使用Run as Administrator选项也是如此。  WindowsError: [Erro...
73
10 回复
如何在身份验证代理后面的窗口上使用pip
我的计算机在Windows服务器上使用代理运行Windows(使用活动目录),我无法弄清楚如何通过pip(在python3中)完成它。我曾尝试使用--proxy,但它仍然只是暂...
6
2 回复
使用pip安装软件包时出错
我正在尝试为python 3.4安装图表工具( matplotlib-v1.4.2 )在Windows 7中,到目前为止我的所有路径似乎都没有完成这项任务。 尝试: 我从 GitHub 下...
问 2年前
116
9 回复
如何在我的Mac上安装pip3?
我正在尝试安装pip3,但我没有运气。此外,我尝试了sudo install,它没有用。我怎么能在我的Mac上安装pip3?  sudo easy_install pip3 Password: Searchin...
问 1年前
2419
35 回复
如何在Windows上安装pip?
pip 是 easy_install 。但是我应该在Windows上使用pip安装easy_install吗?还有更好的方法吗?      2419 虽然我同意你的意见,但所有的Windows程序...
71
14 回复
无法使用pip安装Pygame
我正在尝试安装Pygame。我使用Enthought Python Distribution运行Windows 7。我成功安装了pip,但是当我尝试使用pip安装Pygame时,出现以下错误:   “由...
问 4年前
85
6 回复
使用requirements.txt进行安装时,停止单个包上的pip失败
我正在从requirements.txt安装包    pip install -r requirements.txt requirements.txt文件显示为:  Pillow lxml cssselect jieba beautifulsoup...
问 5年前
90
13 回复
如何使用pip在Windows上安装PyQt4?
我在Windows上使用Python 3.4。当我运行脚本时,它会抱怨  ImportError: No Module named 'PyQt4' 所以我尝试安装它,但是pip install PyQt4给出了   ...
15
1 回复
在ubuntu gcc错误中安装pip geoip
我尝试在python pip中的ubuntu中安装geoip ...但是有同样的gcc错误  pip install GeoIP gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wa...
问 5年前
156
15 回复
无法安装Python包[SSL:TLSV1_ALERT_PROTOCOL_VERSION]
我正在尝试使用pip安装Python库,收到SSL错误:  ~/projects/base  pre-master± pip install xdict Collecting xdict Could not fetch URL https://p...
40
1 回复
pip安装PIL失败
我正在尝试安装pip包PIL。但是,安装不起作用会引发以下错误。  Could not find a version that satisfies the requirement pil (from xhtml2pdf==0.0.4-&...
45
4 回复
如何在Ubuntu 16.10上安装Python 3.6的pip?
我首先要指出这个问题可能看似重复,但事实并非如此。我在这里看到的所有问题都是关于Python 3的pip,我在谈论Python 3.6。当时使用的步骤不适用于Python 3...
21
3 回复
安装GDAL时出错
我正在尝试通过pip安装GDAL。但是我收到了这个错误:  extensions/gdal_wrap.cpp:3089:27: fatal error: cpl_vsi_error.h: No such file or directory...
问 3年前
52
7 回复
修补sslv3问题的pyopenssl
我在使用python 2.7.9-2 amd64的Debian 8系统上遇到了问题:   marius@pydev:/usr/lib/python2.7/dist-packages/urllib3/contrib$ pip search doo Trac...
12
9 回复
安装mysql-python时出错:找不到-lssl的库
我在安装mysql-python时遇到问题。创建了一个新的virtualenv,并在安装mysql-python时...这里是错误消息:  (env)$ pip install mysql-python Collecting...
36
6 回复
由于ssl模块不可用,pip3安装在虚拟环境中,python3.6失败
   (py36venv)vagrant @ pvagrant-dev-vm:/vagrant /venvs $pip3 install pep8       pip配置了需要TLS /SSL的位置,但是Python中的ssl模块不可用。...
问 1年前
465
27 回复
如何在Python上用“pip”安装psycopg2?
我正在使用 virtualenv ,我需要安装“psycopg2”。 我做了以下事情:  pip install http://pypi.python.org/packages/source/p/psycopg2/psycopg2-2.4.tar...
91
15 回复
用pip安装后,“jupyter:command not found”
用pip install jupyter安装后,终端仍无法找到jupyter notebook。 Ubuntu只是说command not found。与ipython相似。 pip没有正确安装或什么? Ubuntu如...
问 3年前
20
10 回复
Python - 无法在Windows中找到pip.ini或pip.conf
我在我的Win7机器上安装了Python 2.7.8,它已预先安装了pip。我已成功安装pip的新软件包,现在我需要在安装时添加自定义存储库URL点子列表 为此,我需要根...
20
4 回复
在Docker Alpine上安装numpy
我正在尝试在基于Alpine 3.1的docker容器中安装numpy。我正在使用以下Dockerfile:  FROM alpine:3.1 RUN apk add --update make cmake gcc g++ gfortran...
问 3年前
23
8 回复
如何从windows cmd上的pip安装pandas?
我正在尝试使用pip安装pandas来运行一些基于pandas的Python程序。我已经安装了pip。我尝试使用谷歌搜索和SO'ing但没有找到解决此错误的方法。有人可以分享...
问 1年前
35
7 回复
在ubuntu上将python3.4升级到python3.6会破坏pip
我正在尝试在我目前拥有python3.4之后在我的机器上安装python3.6。但是,安装后试图在python3.6下运行pip给我错误:  Traceback (most recent call last):...
问 2年前
20
8 回复
在Mac OS X 10.7上无法在virtualenv中使用pip安装psycopg2
我正在关注Heroku的教程来部署Django应用程序: http://devcenter.heroku.com/articles/django# 的先决条件。 一切正常,直到我到达这一部分:  $ pip i...