سؤال تثبيت npm / nodejson ubuntu


sudo apt-get install npm

ثم أحصل على هذا:

The following packages have unmet dependencies:

     npm : Depends: nodejs but it is not going to be installed
           Depends: node-abbrev (>= 1.0.4) but it is not going to be installed
           Depends: node-ansi but it is not going to be installed
           Depends: node-archy but it is not going to be installed

حتى nodejs صعبة موجودة على النظام ، وينبغي لي أن تثبت بشكل منفصل كل تبعية كيف يمكنني تثبيتها في حفنة واحدة؟

لقد حاولت أيضا هذا:

sudo apt-get install nodejs-dev

واحصل على هذا:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nodejs-dev : Depends: nodejs (= 0.10.25~dfsg2-2ubuntu1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

لماذا تقول أن nodejs غير موجود ، إذا كان مثبتًا على النظام بالفعل ؟، إذا ما تم كسره كيف يمكنني إصلاحه؟ لقد حاولت إزالته وتثبيته مرة أخرى ، ولكن لم يساعد ، أي أفكار؟

تصحيح

npm:
  Installed: (none)
  Candidate: 1.3.10~dfsg-1
  Version table:
     1.3.10~dfsg-1 0
        500 http://kg.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status
nodejs:
  Installed: 4.2.1-2nodesource1~trusty1
  Candidate: 4.2.1-2nodesource1~trusty1
  Version table:
 *** 4.2.1-2nodesource1~trusty1 0
        500 https://deb.nodesource.com/node_4.x/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status
     0.10.25~dfsg2-2ubuntu1 0
        500 http://kg.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
node-abbrev:
  Installed: 1.0.4-2
  Candidate: 1.0.4-2
  Version table:
 *** 1.0.4-2 0
        500 http://kg.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status
node-ansi:
  Installed: 0.2.1-1
  Candidate: 0.2.1-1
  Version table:
 *** 0.2.1-1 0
        500 http://kg.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status
node-archy:
  Installed: 0.0.2-1
  Candidate: 0.0.2-1
  Version table:
 *** 0.0.2-1 0
        500 http://kg.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status

2
2017-10-21 07:02


الأصل


ما هو إصدار Ubuntu الخاص بك؟ - hg8
أيضا ، هنا ربما: askubuntu.com/questions/312536/ubuntu-install-nodejs-npm؟rq=1 - KGIII
دعنا تابع هذه المناقشة في الدردشة. - A.B.
sudo apt-get install --reinstall nodejs - A.B.
مرة أخرى خرج apt-cache policy npm nodejs node-abbrev node-ansi node-archy - A.B.


الأجوبة:


أولاً ، نحاول فرض تثبيت الحزم الضرورية

sudo apt-get install node-abbrev node-ansi node-archy 
sudo apt-get install --reinstall nodejs

و بعد apt-cache policy npm nodejs node-abbrev node-ansi node-archy تمتلك هذا

npm:
  Installed: (none)
  Candidate: 1.3.10~dfsg-1
  Version table:
     1.3.10~dfsg-1 0
        500 http://kg.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status
nodejs:
  Installed: 4.2.1-2nodesource1~trusty1
  Candidate: 4.2.1-2nodesource1~trusty1
  Version table:
 *** 4.2.1-2nodesource1~trusty1 0
        500 https://deb.nodesource.com/node_4.x/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status
     0.10.25~dfsg2-2ubuntu1 0
        500 http://kg.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
node-abbrev:
  Installed: 1.0.4-2
  Candidate: 1.0.4-2
  Version table:
 *** 1.0.4-2 0
        500 http://kg.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status
node-ansi:
  Installed: 0.2.1-1
  Candidate: 0.2.1-1
  Version table:
 *** 0.2.1-1 0
        500 http://kg.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status
node-archy:
  Installed: 0.0.2-1
  Candidate: 0.0.2-1
  Version table:
 *** 0.0.2-1 0
        500 http://kg.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status

وبما أنني لا أحصل على مزيد من التعليقات منك

sudo rm /etc/apt/sources.list.d/nodesource.list
sudo apt-get update
sudo apt-get install nodejs=0.10.25~dfsg2-2ubuntu1
sudo apt-get install -f
sudo apt-get install npm

0
2017-10-21 08:40