سؤال الوحدة لن تعلق على عدم النشاط


تشغيل 12.04. يمكنني تعليق النظام يدويًا وإيقاظه مرة أخرى ، ولكن لا يمكنني تعليقه عند عدم النشاط تلقائيًا.

أضبطه على "تعليق عندما تكون غير نشطة لمدة" 10 دقائق في إعدادات الأنظمة> الطاقة. انها مجرد الفراغات الشاشة ، ولكن لا تعليق.

المعلومات على النحو المطلوب. ترك النظام الأيسر دون تغيير في الساعة 18:30 مع تعليق لمدة 10 دقائق.

كان kern.log و dmesg لا شيء جديد فيها.

كان sys.log يحتوي على هذه الخطوط الإضافية

Aug 23 18:34:26 Ubuntu-desktop AptDaemon: INFO: Quitting due to inactivity
Aug 23 18:34:26 Ubuntu-desktop AptDaemon: INFO: Quitting was requested
Aug 23 18:39:01 Ubuntu-desktop CRON[3228]: (root) CMD (  [ -x /usr/lib/php5/maxlifetime ] && [ -d /var/lib/php5 ] && find /var/lib/php5/ -depth -mindepth 1 -maxdepth 1 -type f -cmin +$(/usr/lib/php5/maxlifetime) ! -execdir fuser -s {} 2>/dev/null \; -delete)

2
2017-08-23 04:08


الأصل


بعد التأكد من محاولة النظام الخاص بك تعليق / شاشة فارغة مرة على الاقل، بدون إعادة التشغيل ، يرجى مشاركة محتوى أو إخراج الأوامر / الملفات التالية لمساعدتنا بشكل أفضل في حل مشكلتك (تعليمات في هذه الإجابة): ملف (ملفات): /var/log/kern.log، /var/log/syslog، الأمر (الأوامر): dmesg - ish
تم نشر معلومات إضافية قليلة جدًا على ملفات السجل ، ولكني قمت بتعديل سؤالي مع ما تمت إضافته عندما ذهب النظام إلى شاشة فارغة بدون تعليق. - Jazz


الأجوبة:


حسنًا ، تمكنت أخيرًا من تعليقه تمامًا على عدم النشاط.

بالإضافة إلى إعدادات النظام> ضبط الطاقة لإيقاف التشغيل بعد 10 دقائق ، اضطررت إلى تعيين إعدادات النظام> السطوع والقفل لإيقاف تشغيل الشاشة بعد 10 دقائق.

بالتأكيد إذا كانت هذه الإعدادات 2 تعتمد على بعضها البعض يجب أن تكون معا في قسم واحد من إعدادات النظام؟ تبدو الطريقة التي يتفاعلون بها خاطئًا ، ولا يلمح قسم Systems Settings> Power أو يحذر من أنه لا يمكن تعيينه بشكل مستقل.


1
2017-08-26 00:00



كنت أعاني من مشاكل مماثلة مع نظامي الذي لا ينام. أخذت نصيحتك هنا ، وحلت مشاكلي. الشيء هو ، الآن يبدو أنه يعمل بشكل جيد إذا قمت بإعادة جميع الإعدادات الخاصة بي! ربما كان تبديل كل ما هو مطلوب. FWIW ، يمكنني الحصول على إعدادات 2 مختلفة الآن. عن طريق محرر dconf ، أنا أيضاً قمت بتشغيل org.gnome.desktop.lockdown disable-lock-screen (true true) ويمكن أن تترك كل من org.gnome.desktop.screensaver lock-enabled و ubuntu-lock-on-Suspend إما صحيحة أو خاطئة. - Sparhawk
لاحظ أيضًا أن التوقيت غير صحيح. مثلا (عبر dconf) يمكنني تعيين org.gnome.settings-daemon.plugins.power sleep-display-ac و sleep-inactive-ac-timeout إلى 5 و 5 ، وسيعملون في 30 و 70. وبالمثل ، 60 و 60 النتائج في الكمبيوتر تعليق حوالي 90 ثانية. - Sparhawk
أنا قدمت للتو بق لهذه القضية الثانية. - Sparhawk


كان نفس المشكلة في 12.04 ، ثابتة عن طريق تحديد org.gnome.settings-daemon.plugins.power sleep-display-battery إلى قيمة أقل من قيمة sleep-inactive-battery-timeout.


0
2017-09-11 05:11