سؤال خفض مستوى libxml2 في 12.04


لسبب ما ، على أحد الخوادم التي لدينا في شبكتنا التي تعمل بنظام Ubuntu Server 12.04 ، فإن إصدار libxml2 هو 2.8.0 (وهو واحد من Ubuntu 12.10).
هذا يخلق بعض المشاكل ، خاصة لأنني بحاجة إلى تثبيت libxml2-dev وأحصل على بعض الاعتمادات التي لم يتم الوفاء بها. أحصل على الخطأ التالية:

libxml2-dev : Depends: libxml2 (= 2.7.8.dfsg-5.1ubuntu4.9) but 2.8.0+dfsg1-5ubuntu2.2 is to be installed

لا أعرف سبب وجود الإصدار الأحدث من libxml2 على النظام ، ولكن هناك طريقة لاستخدام الإصدار الجديد من libxml2-dev (وهو غير موجود في المصادر الافتراضية. قائمة) أو بسلام تخفيض libxml2 إلى الإصدار الصحيح ل 12.04؟


2
2017-07-24 09:15


الأصل




الأجوبة:


محاولة:

apt search libxml2

يعرض هذا الأمر البحث من أي دليل: المستودعات والحزم المثبتة.

حتى إذا كنت سترى على سبيل المثال ل موثوق:

libxml2/trusty-updates,trusty-security,now 2.9.1+dfsg1-3ubuntu4.3 amd64
[installed]
  GNOME XML library

libxml2-dbg/trusty-updates,trusty-security 2.9.1+dfsg1-3ubuntu4.3 amd64
  Debugging symbols for the GNOME XML library

libxml2-dev/trusty-updates,trusty-security,now 2.9.1+dfsg1-3ubuntu4.3 amd64
  [installed,automatic]
  Development files for the GNOME XML library

لذلك ، من الواضح ، إذا كنت ترى هذا الإخراج لديك الكثير من فرص لتثبيت الإصدار.

ولكن إذا كنت بحاجة إلى الحزمة بدقة بالإصدار ، فجرّب الإشارة إلى الإصدار على حد سواء:

sudo apt-get install libxml2=2.9.1+dfsg1-3ubuntu4.3
sudo apt-get install libxml2-dbg=2.9.1+dfsg1-3ubuntu4.3
sudo apt-get install libxml2-dev=2.9.1+dfsg1-3ubuntu4.3

أو بالإشارة إلى مستودع المستهدف:

sudo apt-get install libxml2/precise libxml2-dbg/precise libxml2-dev/precise 

بعد تثبيته ، شغّل الأمر التالي لاستيعاب الإصدار المثبت ، ومنع مدير الحزم من تحديثه تلقائيًا في المستقبل:

sudo echo "libxml2 hold" | sudo dpkg –set-selections

مع --no-remove اختيار apt-get سيخرج من عملية التثبيت في أي وقت دون أي مطالبات إذا تم إزالة أي حزم:

sudo apt-get install --no-remove libxml2=2.7.8.dfsg-5.1ubuntu4.9

كيتي أخرى: --no-install-recommends التي تدعي apt-get لا نعتبر الحزم الموصى بها كاعتمادية للتثبيت.

اقرأ apt-get pangolin manpages دقيقة

آمل أن يساعدك.


2
2017-07-24 09:56



شكرا على الأفكار. حاولت القيام apt-get install libxml2=2.7.8.dfsg-5.1ubuntu4.9 ويبدو أنه يعمل لكن يطالب بإزالة 76 حزم في هذه العملية ... - Mircea M
استعمال: apt-get install --no-remove libxml2=2.7.8.dfsg-5.1ubuntu4.9 مع --no-remove اختيار apt-get سيخرج من عملية التثبيت في أي وقت دون أي مطالبات إذا كان سيتم إزالة أي حزم. كما سيكون هناك خيار آخر مفيد لك: --no-install-recommends التي تدعي apt-get لا نعتبر الحزم الموصى بها كاعتمادية للتثبيت. للقيام: تحديث الإجابة. - swift
بعد تثبيته ، شغّل الأمر التالي لاستيعاب الإصدار المثبت ، ومنع مدير الحزم من تحديثه تلقائيًا في المستقبل: sudo echo “package hold” | sudo dpkg –set-selections - swift
شكر كبير حقا لجميع المساعدة. لقد جربت ما اقترحته وحصلت على هذا: 0 upgraded, 0 newly installed, 1 downgraded, 76 to remove and 12 not upgraded. E: Packages need to be removed but remove is disabled. - Mircea M