سؤال Battle.net لن يفتح


لقد قمت بتركيب Ubuntu 14.04 قبل بضعة أسابيع على نظامي وكان كل شيء يعمل بشكل جيد. اليوم ذهبت لاستخدام Battle.net وكل ما حصلت عليه كان نافذة بيضاء متبوعة برسالة خطأ عامة. لقد حاولت حل هذا كل يوم. الرجاء المساعدة!

أنا أستخدم النبيذ 1.7.38.


2
2018-04-18 20:55


الأصل


إنه تطبيق سطح مكتب يستخدم لتثبيت وتشغيل ألعاب Blizzard. هو ملف .exe ، ولكن كان لي العمل باستخدام النبيذ وتوقف فجأة. - nny1126
هل تستخدم محول رسومات Intel؟ - David Foerster
ذات صلة: askubuntu.com/questions/455508/... - Elder Geek


الأجوبة:


أصدر الأمر: sudo add-apt-repository ppa:ubuntu-wine/ppa

تليها

sudo apt-get update وثم

sudo apt-get install wine1.8 winetricks

إذا قمت بتثبيت wininet من winetricks فإنه يضيف تلقائياً الإعدادات الصحيحة في المحطة ، اكتب:

winetricks wininet allfonts

يقوم الأمر الموضح أعلاه بتثبيت كل من wininet والعديد من خطوط النوافذ. لست متأكداً من أن هذا ضروري للغاية ولكن لا ينبغي أن يحدث أي ضرر.

في النهاية تشغيل winecfg من المحطة أو ابحث عن "Configure Wine" في قائمة سطح المكتب. اذهب إلى علامة التبويب "المكتبات". يجب أن تشاهد wininet (الأم ، بنيت) المدرجة بالفعل هناك. إذا لم يكن كذلك ، ضعه هناك

في الحقل المسمى "تجاوز جديد للمكتبة" ، اكتب في: dbghelp انقر فوق إضافة لوضعها في القائمة والتأكيد مع نعم على المنبثقة. اضغط على dbghelp (native,builtin) هذا هو الآن في القائمة انقر فوق تحرير اختر تعطيل انقر فوق موافق"

في الحقل المسمى "تجاوز جديد للمكتبة" ، اكتب في: msvcp100 انقر فوق إضافة انقر فوق موافق

أنت مستعد تمامًا. قم بتنزيل وتثبيت العميل انت تريد.

EDIT: لاحظ أن حزمة النبيذ الحالية المتاحة في ppa قد تختلف حسب مرور الوقت وإصدار Ubuntu الذي تقوم بتشغيله وبينما تم تأكيد هذه الإجابة مع النبيذ 1.7 في وقت كتابة هذه الإجابة قد تختلف المسافة المقطوعة. يمكنك التحقق لمعرفة الحزمة المتوفرة حاليًا من PPA لإصدار Ubuntu الخاص بك هنا. لمزيد من التفاصيل عن اختبارات النبيذ الأخيرة للقاذفة Battle.net على أوبونتو 16.04 انظر هنا

مصدر: http://brockhatfield.com/2014/01/23/hearthstone-linux-wine/


4
2018-04-18 21:14





وفقا لهذا الاختبار على النبيذ المقر، 14.04 لا يعرض أي شيء باستثناء على خلفية سوداء. أنت في حاجة إلى أوبونتو 14.10 حتى يعمل. للحصول على 14.10 ، قم بتشغيل sudo apt-get dist-upgrade.


0
2018-04-18 21:05



سأحاول ترقية الآن. شكرا لكم. - nny1126
يبدو أن اختبار الرجل في 14.04 لا يعرف حقا ، ما كان يفعله. بحسب ال gold-rated 14.10 entry تكمن المشكلة في برامج تشغيل الرسومات: "بالنسبة إلى intel ، قد يظهر المشغل مشوهًا أو أسود تمامًا بدون برامج تشغيل محدّثة." - David Foerster
DavidFoerster يشير بحثي إلى أن المشكلة قد تكون مع dbghelp - Elder Geek
DavidFoerster ربما لم يفعل ذلك ، ولكن قد يذهب OP إلى 14.10 ، حيث إنه يعمل على ذلك بالتأكيد. - TheWanderer
لا ، وفقًا للإدخال المذكور ، لا يعمل "بالتأكيد" في 14.10 ، إذا كان لدى أحدهم محول رسومات Intel. - David Foerster