سؤال كيفية تخطي مربع حوار "تنفيذ الملف" في lubuntu (PCManFM)


عندما أنقر على ملف تنفيذي في PCManFM (مدير الملفات الافتراضي في Lubuntu) ، أحصل على مربع حوار "Execute File" مع ثلاثة خيارات (تنفيذ ، تنفيذ في طرفية ، إلغاء). هل هناك طريقة لتعيين الإجراء الافتراضي (على سبيل المثال ، تنفيذ) لتخطي مربع حوار "تنفيذ الملف" المزعج؟


2
2017-08-16 07:20


الأصل




الأجوبة:


أعلم أن هذا قد يكون قديمًا ولكنه قد يساعد شخصًا ما.

ببساطة قم بإنشاء ملف .desktop مع المحتوى التالي

[Desktop Entry]
Type=Application
Icon=path/icon.png
Name=Name
Comment=Description       
Categories=Applications
Exec=/path/to/yout/exec
StartupNotify=true
Terminal=false

احفظه مثل myexec.desktop وأنت جيد للذهاب.

عملت بالنسبة لي ووجدت أن أفضل طريقة لتغيير السلوك الافتراضي لمدير الملفات (بالإضافة إلى أنني لم أجد الطريقة في كل مكان قرأت سوى عن نوتيلوس).


4
2017-08-09 01:58



هذا ليس بالضبط الإجابة على السؤال كيفية تجنب هذا الحوار تماما لجميع الملفات التنفيذية. لذا فأنا أجرِ 1+ ، لكن لا أضع علامة كإجابة على أمل أن يقدم أحد الأشخاص الإجابة في يوم من الأيام. - Artem Pelenitsyn


افتح PCManFM ، انتقل إلى Edit / Preferences / General ، حدد خانة الاختيار "لا تطلب خيارات عند تشغيل ملف قابل للتنفيذ"


2
2017-10-22 21:43



رائع ، شكرا !، هذه هي الإجابة الصحيحة :-) - ArianJM


كحل بديل ، إذا كان لديك ملف مثير للاهتمام محددًا ، فسيؤدي الضغط مرتين مفتاح المسافة أو الإدخال إلى تشغيله كما تشاء ، لأن Execute هو الزر الافتراضي ، للإجراء الافتراضي.

قد لا يكون من الجيد تعيين Execute كإعداد افتراضي (افتراضيًا :) لأنك قد ترغب أحيانًا في "تنفيذ في الطرفية" أو ببساطة "إلغاء" إذا قمت بالنقر فوق ملف قابل للتنفيذ قمت بفك ضغطه من الإنترنت عن طريق الخطأ.


1
2017-09-09 14:25