سؤال التبعيات غير الملباة في أوبونتو 12.04؟


The following packages have unmet dependencies:
       gstreamer0.10-ffmpeg: Depends: libavcodec-extra-53 (>= 4:0.7-1) but    4:0.7.2.1ubuntu2 is to be installed
                         Depends: libavformat-extra-53 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                         Depends: libavutil-extra-51 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                         Depends: libc6 (>= 2.7) but 2.15-0ubuntu10 is to be installed
                         Depends: libglib2.0-0 (>= 2.24.0) but 2.32.3-0ubuntu1 is to be installed
                         Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu0.1 is to be installed
                         Depends: libgstreamer0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu1 is to be installed
                         Depends: liborc-0.4-0 (>= 1:0.4.14) but 1:0.4.16-1ubuntu2 is to be installed
                         Depends: libpostproc-extra-52 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                         Depends: libswscale-extra-2 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed gstreamer0.10-ffmpeg:i386:    Depends: libavcodec-extra-53 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to   be installed
                              Depends: libavformat-extra-53 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                              Depends: libavutil-extra-51 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                              Depends: libc6 (>= 2.7) but 2.15-0ubuntu10 is to be installed
                              Depends: libglib2.0-0 (>= 2.24.0) but 2.32.3-0ubuntu1 is to be installed
                              Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu0.1 is to be installed
                              Depends: libgstreamer0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu1 is to be installed
                              Depends: liborc-0.4-0 (>= 1:0.4.14) but 1:0.4.16-1ubuntu2 is to be installed
                              Depends: libpostproc-extra-52 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed
                              Depends: libswscale-extra-2 (>= 4:0.7-1) but 4:0.7.2.1ubuntu2 is to be installed



       Package dependencies cannot be resolved
       This error could be caused by required additional software packages    which are missing or not installable. Furthermore there could be a    conflict between software packages which are not allowed to be    installed at the same time.

لقد حاولت اتباع كل التعليمات من هنا ولم تساعدني بعد

ما هي المشكلة وكيف يمكنني إصلاحها؟

تصحيح:
مشكلتي هي أنه لا يمكنني تثبيت Gstreamer ffmpeg video plug-in برامج الترميز لتشغيل ملفات .mpeg و .divx و .mpeg4 و .ac3 و .wmv و .asf


4
2017-08-18 16:13


الأصل


يرجى المحاولة sudo apt-get update أولاً ، ثم تحقق مما إذا كان لا يزال لديك هذا الخطأ. - ish
بالإضافة إلى ذلك قد يساعد إذا ذكرت ما تحاول تثبيته - doug
ليس لدي أي مشكلة مع التحديث .. ما مشكلتي أنا غير قادر على تثبيت Gstreamer ffmpeg برامج ترميز الفيديو المساعد لتشغيل ملفات mpeg ، divx ، mpeg4 ، ac3 ، wmv و asf - santosamaru


الأجوبة:


يبدو أنك تستخدم مكتبات قديمة جدًا ، على سبيل المثال "libavcodec-extra-53 (> = 4: 0.7-1) ولكن 4: 0.7.2.1ubuntu2 هو أن يتم تثبيت ". وقد صدر هذا الإصدار في 12.04 ديف في 2011-12-26 وقد تم استبداله عدة مرات.

الإصدار الحالي 12.04 هو 4: 0.8.3ubuntu0.12.04.1) الأمان الدقيق

حتى فتح مصادر البرامج ، software-properties-gtk & تأكد من أن تحت Ubuntu Software يتم فحص الأول 4 وتحت Updates و 1. 2 يتم فحصها

ثم قم بتحديث مصادرك ونرى


4
2017-08-18 17:05



أفعل ما تقوله ولكن لا يزال يعطي نفس التبعيات التي لم تتم تلبيتها؟ - santosamaru
هل يمكنك فتح مصادر البرامج ، والتبديل إلى main server، الركض sudo apt-get clean && sudo apt-get update. نشر النتائج في ubuntu pastebin واربط في سؤالك - doug
بالنسبة لي هذا لا يعمل ..: / - Pithikos
عملت خدعة خادم مي ، وأنا لا أعرف لماذا لا يتم تحديث الخوادم الأخرى بانتظام. كنت أستخدم خادم PK وكنت أحاول حل المشكلة لمدة يومين. تعيينها إلى الخادم الرئيسي وعملت. - S. A. Malik