سؤال هل من الممكن تحديث برامج تشغيل بطاقة الرسومات الخاصة بي؟


هذا ما يعرض الأمر lspci -v في قسم وحدة تحكم متوافق مع VGA:

00:02.0 VGA compatible controller: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller (prog-if 00 [VGA controller])
Subsystem: Dell Device 048e
Flags: bus master, fast devsel, latency 0, IRQ 44
Memory at f0200000 (32-bit, non-prefetchable) [size=512K]
I/O ports at 18d0 [size=8]
Memory at d0000000 (32-bit, prefetchable) [size=256M]
Memory at f0000000 (32-bit, non-prefetchable) [size=1M]
Expansion ROM at <unassigned> [disabled]
Capabilities: <access denied>
Kernel driver in use: i915
Kernel modules: i915

i915 متوافق فقط مع OpenGL 1.4 ولا يمكنه استخدام تظليل وأود استخدام بعض وظائف Open GL 2.0.

هل من الممكن تحديث برامج التشغيل أم أن أجهزتي تقتصر على OpenGL 1.4؟


4
2017-10-14 14:28


الأصل


هل جربت jockey-gtk؟ هذا يبحث عن برامج تشغيل محدثة أو "إضافية". (مجرد محاولة التحقق من الأشياء البسيطة أولاً.) - Argusvision
لقد حاولت للتو ، لا يجد jockey-gtk أي شيء. - madmaxpt
يمكنك أيضا فتح متشابك والبحث i915. هناك حزمة xserver-xorg-intel التي قد تعمل من أجلك. ليس لدي طريقة لاختباره على أجهزتي. - Argusvision
للإجابة على السؤال الثانوي ، "هل من الممكن تحديث (لاستخدام Open GL 2.0)؟ تشير هذه المقالة إلى نعم. phoronix.com/scan.php؟page=news_item&px=OTk4Mg - Argusvision


الأجوبة:


ليس لدى Intel برامج تشغيل إضافية (برامج تشغيل مقيدة) متوفرة لنظام التشغيل Linux. برامج التشغيل كلها مفتوحة المصدر.

إذا كنت ترغب في تحديث برنامج التشغيل الخاص ببطاقة الرسومات Intel ، يمكنك إضافة PPA حيث تم تضمين أحدث برامج التشغيل وتحديثها من هناك.

مثال. أوبونتو X - فريق

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update 
sudo apt-get dist-upgrade

إذا كنت تريد العودة (التراجع)

sudo apt-get install ppa-purge
sudo ppa-purge ppa:ubuntu-x-swat/x-updates
sudo apt-get update 
sudo apt-get dist-upgrade

4
2017-10-14 14:56



فعلت ما قلته لي ، فإنه تحديث السائقين ، ولكن glxinfo | ما زال الأمر grep version يشير إلى "OpenGL version string: 1.4 Mesa 8.0.2". أي فكرة حول كيفية إخباره باستخدام OpenGL 2؟ - madmaxpt
إذا كانت بطاقة الرسومات (الأجهزة) لا تدعم برنامج OpenGL 2.0 ، فلا يمكن للسائق أن يفعل الكثير (على ما أظن). إلق نظرة هنا ووفقًا لنموذج بطاقة الرسومات ، انظر ما إذا كان يدعم OpenGL 2.0 - Nick Thom
تدعم البطاقة الإصدار 2.0: phoronix.com/scan.php؟page=news_item&px=OTk4Mg - Milan Babuškov
الرابط ميت. - kenorb