سؤال كيف يمكنني خفض مستوى AbiWord إلى الإصدار 2.8.6؟


إصدار AbiWord (2.9.2) الذي تم تثبيته (مع Lubuntu في حالتي) يحتوي على العديد من الأخطاء! هل يعرف أحد ما إذا / عندما يقوم Ubuntu بتبديل هذا إلى الإصدار الثابت (2.8.6)؟


4
2017-07-05 17:55


الأصل


أشك كثيرا في أن ذلك سيحدث. في أي حال ، يمكنك أيضًا الاشتراك في قائمة بريدية Lubuntu ونسأل هناك.
إذا كنت ترغب في إصلاح الأمور بنفسك ، فراجعها هذا الموضوع والاقتراح لتثبيت الإصدار الذي ذكرته من ppa. لاحظ أنني لم أحاول أيًا من هذا.


الأجوبة:


لقد كان لدينا abiword 2.9 للإصدارات 3 الآن ، ولكن يبدو أن ربما تمت إضافته عن طريق الصدفة. على افتراض أن هذا هو الحال ، فإن الإجراء الأكثر منطقية سيكون من المحتمل أن يكون العرض 2.8 للإصدار التالي ، ويوفر منفذًا خلفيًا يسمح للمستخدمين بتثبيته.

يمكن تحقيق ذلك بإحدى الطريقتين التاليتين:

  • تقديم حزمة مسماة بشكل مختلف توفر 2.8 حتى عند توفر 2.9 (على سبيل المثال ، يمكن استدعاء الحزمة abiword-2.8 بدلا من abiword (إذا لم يتم بناؤه بطريقة تسمح بتثبيت كليهما في كل مرة ، يمكن أن تعكس تبعياتها ذلك ، مما يؤدي إلى abiword و abiword-2.8 ليتم تثبيته).

  • تخفيض الإصدار المقدم من قبل abiword (في إصدار لاحق) إلى 2.8 ، ولكن اسمها برقم إصدار أعلى بحيث يتم تثبيتها بالفعل على نظام يحتوي بالفعل على abiword 2.9.

    سلسلة إصدار لأحدث (وفقط) abiword الحزمة في رارينج هو 2.9.2+svn20120603-8. saucy-updates لديها حاليا 3.0.0~svn20130523-1ubuntu2. حزم من الإصدارات الأحدث تحل محل (أي افتراضيا الحصول على تفضيل للتركيب على) الحزم من الإصدارات السابقة.

    ولكن إذا أعطيت حزمة توفير abiword 2.8 سلسلة الإصدار 3.0.0+actually2.8.6، سيرى مدير الحزمة على أنه إصدار أحدث. (يمكن توفير ذلك في PPA أيضًا ، إذا أراد أحد القيام بالعمل ، فقد وجدت أن AbiWord يصعب تجميعها بشكل مفاجئ ، على الأقل عندما أحاول تضمين جميع الميزات التي يمكن أن يتوقعها المرء بشكل معقول. من المحتمل ألا يُطلق على ذلك حزمة رسمية لأنها لا تتوافق مع اصطلاحات التسمية للطرود - الإصدارات الخاصة بـ Ubuntu مثل هذه ubuntu في أسمائهم - لكنني أعتقد أنه يمكن تحقيق ذلك ضمن اصطلاحات التسمية المقبولة.)

بالحديث عن PPA ، أشار vasa1 أن هناك (على الأقل) واحد. ليونيل لو Folgoc في PPA يوفر abiword 2.8.2 (ويستخدم نظام إصدار مثل ذلك الموضح أعلاه: سلسلة الإصدار 2.9.2+svn20120213really2.8.6-0ubuntu0.1~ppa1). ومع ذلك ، لسوء الحظ أن PPA يوفر فقط abiword 2.8.2 for Precise. (إذا قمت بتحديد إصدار مختلف في القائمة المنسدلة "المنشورة" في تلك الصفحة ، فلن تظهر.)

مع كل ما يقال ، حزمة أوبونتو راقيًا لإرادة abiword على الاغلب لا يتم تقديمها رسميا. هذا بسبب:

  • إصدار التطوير من abiword يصبح أفضل وأفضل (بشكل عام ، ومن حيث الاستقرار) مع كل إصدار. ربما تم إصلاح معظم أو كل البق التي واجهتها في إصدار تطوير لاحق. هذا هو السبب في أنها سخيفة لتشمل إصدار تطوير مجمدة في إصدار أوبونتو المستقر - سيكون لديها الكثير من الأخطاء التي لن يتم إصلاحها أبداً ما لم SRU يتم تنفيذ proccess. هذه العملية لم تحدث ل abiword في الإصدارات القليلة الماضية أوبونتو. ولكنه يعني أيضًا أن عرض إصدار التطوير التالي سيعمل على إصلاح معظم الأخطاء.

  • لست متأكداً عندما سيكون لدى أبي ورد 3 إصدار ثابت من المنبع (أي ، إصدار ثابت من مشروع أبي ورد نفسه ، والذي يمكن أن يتم تعبئته من أجل تضمينه الرسمي في أنظمة تشغيل مثل أنظمة ديبيان ، أوبونتو ، وأنظمة جنو / لينكس الأخرى). ولكن يبدو من المرجح أن يكون الإصدار - أو على الأقل نسخة تجريبية - قريبًا. نأمل أن يتم إصداره في الوقت المناسب لجعله في Saucy. إن تغيير رقم الإصدار من 2.9 ... إلى 3.0 ... يعني أن الإصدار سيأتي قريبًا.

  • GTK + 2.0 هو لا يزال تعبئتها للحصول على أحدث إصدارات Ubuntu ، ولكن هناك ضغط على تطبيقات port إلى GTK + 3.0 ، حيث أن ذلك قد يوفر تكاملاً أفضل مع بيئات سطح المكتب الحالية ، ولأن في نهاية المطاف قد يكون GTK + 2.0 إهمال للإزالة.

لقد حاولت أن أقدم إجابة معقولة تشتمل على الصلة   الحقائق ("شخصي جيد"). هذا هو CW لذلك من الأسهل على   أي شخص لتحديث / تحسين. مع ذلك ، إذا كنت تريد أن تبدأ أو   مشاركة في مناقشة كاملة من هذا الموضوع ، في مكان ما   مثل منتديات اوبنتو سيكون أفضل.


4