سؤال LTS Enablement Stacks - هل يجب أن أستخدم الكَمّ ، أو النِّقَم ، أو التَّوَتُّر؟


لقد قمت بتثبيت Kubuntu 12.04 من ISO beta وقمت بتحديثه منذ ذلك الحين. ومع ذلك ، أريد الاشتراك في مكدس تمكين الأجهزة لـ Precise الآن.

لدي سؤالان:

أولا ، كيف أقرر بين الإصدارات؟ على سبيل المثال ، هل أقوم ببساطة باختيار الأحدث؟ (و بذيء متاح لهذا الغرض حتى الآن؟)

sudo apt-get install linux-generic-lts-raring xserver-xorg-lts-raring 

أو

sudo apt-get install linux-generic-lts-saucy xserver-xorg-lts-saucy

ثانيًا ، إذا اخترت مكدس تمكين الأجهزة باستخدام الإصدار المتجدد ، فهل ستكون هناك أية صعوبات أو تحديات تنتقل إلى الإصدارات البذيئة أو اللاحقة لاحقًا؟ وماذا علي أن أفعل في ذلك الوقت؟


4
2017-09-03 14:09


الأصل


@ Braiam-I تثبيت 12.04 منذ وقت طويل! ؛-) - MountainX


الأجوبة:


إن الاختيار بين الكَمّ والشّعر والبارق هو حقٌّ يعود إليك لكنّ هذه المداخن تُسَمَّى بعد الإصدار الذي تبرز فيه. وعلى هذا النحو ، فإن المكدّس الباهت لا يتم إطلاقه حاليًا ويجب اعتباره غير مناسب للإنتاج.

التنقل بين المداخن ممكن. انهم مجرد حزم ، بعد كل شيء.

السيناريو السيئ الوحيد الحقيقي يبدأ من 12.04 ، بتثبيت HWE 13.04 ثم ترقية التوزيع إلى 12.10. سيكون مكدس X الخاص بك أحدث من باقي النظام في تكوين لم يتم اختباره. أوصي بإزالة حزم مكدس HWE قبل الترقية.

ترقية LTS القياسية (على سبيل المثال إلى 14.04) على ما يرام على الرغم من أنك قد تحتاج إلى ترقية HWE يدويًا. يجب أن أشير أيضًا إلى أن 14.04 ، هي مجموعتي الدعم الوحيدتين المدعومة عند 12.04 هي المجموعة الأصلية و 14.04 (والتي ستستمر في الدعم للسنوات الثلاث المتبقية من عمر 12.04).


4
2017-09-03 14:33



حتى أتمكن من تثبيت كومة HWE متألقة الآن وعندما يتم إصدار بذيء سأفعل apt-get remove linux-generic-lts-raring xserver-xorg-lts-raring و apt-get install linux-generic-lts-saucy xserver-xorg-lts-saucy. صيح؟ - MountainX
أيضا ، عندما يخرج 14.04 ، أخطط للترقية من 12.04 إلى 14.04. أفترض أنه إذا كان لدي كومة HWE مثبتة ، فستحتاج إلى إزالتها لإجراء الترقية إلى 14.04. صيح؟ - MountainX
1) إذا كنت ترغب في الترقية إلى كومة HWE بذيء ، نعم. 2) أنا بصراحة لست متأكدا ما سيكون عليه الوضع لترقيات كبيرة. أفترض أنه سيتم إزالتها تلقائيًا بواسطة المثبت ، ولكن حتى إذا لم تكن كذلك ، فسيتم تجاوزها بإصدارات 14.04 لذا لا ينبغي أن يتسبب ذلك في حدوث تعارض. يكلف القليل من الوقت لإزالتها قبل القيام بالأشياء بحيث قد يكون مجرد طريقة أكثر أمنا. - Oli♦