سؤال توقف اللكنات عن العمل فجأة في Libreoffice


يمكنني كتابة شخصيات مثل á، é، ó، ã، ê، etc، fine in Kubuntu 14.04.

حتى في LibreOffice.

ومع ذلك ، إذا قمت بتحويل النوافذ من LibreOffice إلى ، مثلاً ، Chrome أو Dolphin ، ثم عدت مرة أخرى إلى LibreOffice ، فلن تسجل هذه الأحرف بعد الآن ، وستكتب بدلاً من ذلك a ، e ، o ، a ، e ستكتب ، بدون أي لهجات .

هذا أمر مزعج للغاية ولقد كنت تافه مع إعدادات نظام كيدي للساعتين الماضيتين دون جدوى. أنا حقا أحب بعض المساعدة.

شكرا مقدما،


4
2018-04-21 05:54


الأصل


ربما ستجد الإجابة / الحل هنا: askubuntu.com/questions/367745/keyboard-language-self-switches. السبب (على ما أظن) هو نفسه. ربما يكون الجواب على nux هو ما تحتاج إلى القيام به. - Jacob Vlijm


الأجوبة:


كان عندي نفس المشكلة بالضبط. وألاحظ أيضًا أن هذه المشكلة تتعلق بـ KDE و IBUS. الحل أعلاه لم يعمل على الإطلاق. يبدو أن هناك مشكلات أخرى مشابهة قد تكون مرتبطة بتوليفة هذه المجموعة (KDE، ibus، libreoffice-kde). أنا حلها في نظام بلدي عن طريق إزالة ليبر أوفيس-كيدي والحفاظ عليها ليبر أوفيس-جنوم.

الروابط التي قد تساعد:

  1. نفس المشكلة ، في فيدورا 16 ، والحل في التعليق ن. 5: https://bugzilla.redhat.com/show_bug.cgi؟id=825067

  2. نفس الشيء ، في openSUSE: http://forums.opensuse.org/showthread.php/473607-Ibus-don-t-work-in-Libreoffice-٪28Opensuse-12-1٪29


3
2018-05-24 17:59





ما ساعدني هو إزالة حزمة libreoffice-kde.

أنا أيضا إلغاء تثبيت جميع اللغات الإنجليزية في KDE و Unity وترك واحد فقط (بلدي ، التشيكي).

الآن يبدو موافق حتى أعتقد أن إزالة حزمة libreoffice-kde كان وسيلة للمساعدة في ذلك.


1
2018-06-03 12:11





أعطاني يعقوب فليغم هذا الرابط المفيد للغاية:

مفاتيح لوحة المفاتيح ذاتية اللغة

كان الحل الذي أقدمه هو Adobe. لقد قتلت ibus وعمل كل شيء. بعد أن وجدت الجاني ، فتحت مرة أخرى وذهبت من خلال تفضيلاتها لإصلاح المشكلة.


0
2018-04-21 18:19



عملت كل شيء حتى بدأت تواجه مشاكل مع كروم. الآن مع ibus ، كسر Libreoffice. بدون ibus ، يكون Chrome معطلًا. سأحاول تجربة خيار Luan Carvalho أعلاه ونرى ما إذا كان يعمل! - Peterson Silva


كان لي نفس المشكلة ، وأنا لم إلغاء تثبيت libreoffice-kde وأنها تعمل

sudo apt-get autoremove libreoffice-kde

0
2017-08-13 04:38





التحرير /etc/default/locale وإعادة التشغيل بعد حلها أيضا. يحدث هذا الموقف عندما يكون هناك عدة لغات محددة في "اللغة". الذي يعمل هو الإعداد LANG="en_US.UTF-8" وكل الآخرين pt_PT.UTF-8 مع LibreOffice باللغة الإنجليزية ، والبرتغالية للباقي. أو مجرد تغيير اللغة.


0
2017-10-13 09:43