سؤال كيفية تثبيت الإصدار السابق من Maven (3.0.4)؟


الطريقة التي يتم بها تكوين حزم Maven الخاصة بي ، فواصل شيء ما عند تثبيت أحدث إصدار (على ما أظن 3.4). على كمبيوتر آخر ، حيث لدي 3.0.4 ، يعمل البناء بشكل جيد. أنا أبحث عن طريقة لتثبيت إصدار سابق باستخدام apt-get. تتبعت هذه التعليمات وأنهم أتموا بشكل جيد ولكن عندما ركضت mvm -v، حصلت على الخطأ التالي ، لذلك يجب أن يكون هناك خطأ ما في الكرة القطران:

[ERROR] مرحلة دورة حياة غير معروفة "–v"


4
2018-05-14 22:34


الأصل


هل فكرت بمحاولة إصلاح البنية في الإصدار الحالي من Maven؟ أيضا ، إصدار maven في repos هو 3.0.5. - saiarcot895


الأجوبة:


  1. قم بتنزيل واستخراج حزمة التثبيت:

    cd /opt
    wget -O- https://archive.apache.org/dist/maven/maven-3/3.0.4/binaries/apache-maven-3.0.4-bin.tar.gz |
    sudo tar -xzv
    
  2. إضافة /opt/apache-maven-3.0.4/bin لك PATH.

أنظر أيضا http://maven.apache.org/download.cgi.


4
2018-05-22 21:57



التحديث: الرابط لا يعمل. استخدم هذا واحد بدلا من ذلك: archive.apache.org/dist/maven/maven-3/3.0.5/binaries/... - Marc Guiselin
وإزالة .gz في الخطوة الرابعة - Marc Guiselin
قم بإضافة / bin إلى نهاية ذلك المسار في الخطوة 9 - Marc Guiselin


يمكنك تثبيت maven 3.0.4 مع المؤسسة العامة للتقاعد: rockclimb / نتبيانس مستودع.

sudo add-apt-repository ppa:rockclimb/netbeans

sudo apt-get update

sudo apt-get install maven

0
2018-05-22 21:50