سؤال التبعية ليست خطأ مرضية مع libdbus


عند محاولة تثبيت .deb حزمة أحصل على هذا الخطأ

Dependency is not satisfiable: libdbus-1-3 (>= 1.9.14)

جربت هذه الأوامر دون جدوى:

apt-get clean
apt-get update
apt-get dist-upgrade
apt-get install -f
apt get -a --configure

لست متأكدًا من كيفية المتابعة من هنا


4
2018-03-25 18:19


الأصل


لا تفعل عشوائية aptations apt. يمكنك أن تفعل الكثير من الضرر. - user535733
أنا فقط حاولت ث / ه ppl مما يوحي في ترتيب المواضيع - Robpuff


الأجوبة:


المشكلة هو أن Ubuntu 14.04 يستخدم الإصدار libdbus-1-3 1.6.18. لهذا السبب لا يمكنك تثبيت حزمة تتطلب 1.9.14 أو أعلى.

حل واحد بسيط هو الترقية إلى إصدار أحدث من أوبونتو. على سبيل المثال ، يستخدم Ubuntu 16.04 الإصدار 1.10.6 من libdbus-1-3.

حل بسيط آخر هو استخدام إصدار قديم من البرنامج الذي تريد تثبيته. يشير الشرط الخاص بالإصدار 1.9.14 من libdbus-1-3 إلى أنه ليس من مستودع Ubuntu مدعوم حاليًا على أي حال.

وإليك طريقة واحدة سهلة لفهم الإصدارات المختلفة التي يقدمها كل إصدار (ومستودع) من أوبونتو:

$ rmadison libdbus-1-3
 libdbus-1-3 | 1.4.18-1ubuntu1    | precise          | amd64, armel, armhf, i386, powerpc
 libdbus-1-3 | 1.4.18-1ubuntu1.8  | precise-security | amd64, armel, armhf, i386, powerpc
 libdbus-1-3 | 1.4.18-1ubuntu1.8  | precise-updates  | amd64, armel, armhf, i386, powerpc
 libdbus-1-3 | 1.6.18-0ubuntu4    | trusty           | amd64, arm64, armhf, i386, powerpc, ppc64el
 libdbus-1-3 | 1.6.18-0ubuntu4.4  | trusty-security  | amd64, arm64, armhf, i386, powerpc, ppc64el
 libdbus-1-3 | 1.6.18-0ubuntu4.5  | trusty-updates   | amd64, arm64, armhf, i386, powerpc, ppc64el
 libdbus-1-3 | 1.8.12-1ubuntu5    | vivid            | amd64, arm64, armhf, i386, powerpc, ppc64el
 libdbus-1-3 | 1.10.6-1ubuntu3    | xenial           | amd64, arm64, armhf, i386, powerpc, ppc64el, s390x
 libdbus-1-3 | 1.10.6-1ubuntu3.1  | xenial-security  | amd64, arm64, armhf, i386, powerpc, ppc64el, s390x
 libdbus-1-3 | 1.10.6-1ubuntu3.3  | xenial-updates   | amd64, arm64, armhf, i386, powerpc, ppc64el, s390x
 libdbus-1-3 | 1.10.10-1ubuntu1   | yakkety          | amd64, arm64, armhf, i386, powerpc, ppc64el, s390x
 libdbus-1-3 | 1.10.10-1ubuntu1.1 | yakkety-security | amd64, arm64, armhf, i386, powerpc, ppc64el, s390x
 libdbus-1-3 | 1.10.10-1ubuntu1.1 | yakkety-updates  | amd64, arm64, armhf, i386, powerpc, ppc64el, s390x
 libdbus-1-3 | 1.10.10-1ubuntu1.2 | yakkety-proposed | amd64, arm64, armhf, i386, powerpc, ppc64el, s390x
 libdbus-1-3 | 1.10.10-1ubuntu2   | zesty            | amd64, arm64, armhf, i386, ppc64el, s390x

4
2018-03-25 18:51



سوف تحديث إلى 16.04.2 beacuse البرامج أحتاج لا تسمح الإصدارات القديمة ، تاي للإجابة الخاصة بك! - Robpuff


جرب هذا:

dpkg --force-all -i opera-stable_51.0.2830.55_amd64.deb 

ستقوم المعلمة --force- all بتثبيت حزمة Opera على الرغم من مشكلة التبعية. حظا طيبا وفقك الله.


3
2018-03-19 15:05



أنا عادة لا أنصح أي شخص يفعل --force-allولكن هذه "الإجابة" تسمح بتثبيت أوبرا Opera وفتحها ، وهو ما قد يكون مطلوبًا للمنظمات الملصقة على Ubuntu 14.04. i.imgur.com/zDD3Hj0.gifv - tresf