سؤال كيف يمكن تمكين OpenGL 2.0 و WebGL على GMA 3150؟


لدي Dell Mini 1012 الذي يحتوي على معالج Intel N450 و GMA 3150 بطاقة رسومات مدمجة تعمل بنظام Ubuntu 10.10. وفقا لموقع إنتل ، تدعم بطاقة الرسومات OpenGL 2.0.

http://software.intel.com/en-us/articles/quick-reference-guide-to-intel-integrated-graphics/#9 

لكن عندما اكتب glxinfo في محطة سلسلة إصدار OpenGL يعطيني ما يلي

OpenGL version string: 1.4 Mesa 7.9-devel

لقد قمت بتثبيت أحدث برامج التشغيل لكنها لم تنجح. لذا ، كيف يمكنني تمكين OpenGL 2.0 على هذه البطاقة؟


11
2018-01-01 08:46


الأصل




الأجوبة:


  1. التثبت driconf من مركز البرامج.

  2. صحافة البديل + F2 واكتب driconf واضغط على دخول.

  3. يتغيرون تمكين دعم ARB_fragment_shader محدود على 915/945 من عند لا إلى نعم فعلا من خلال النقر على الزر المجاور لها


8
2018-04-26 15:32



هذا قد يحل مشكلة كنت أواجه مع أجهزة الكمبيوتر المحمولة 2 dv6700. - Luis Alvarado♦
شكرًا لك: Dell Inspiron Mini 1012 هنا أيضًا ، Ubuntu 16.04 (يتم تمرير المرات) أحدث ، لن تستخدم mpv OpenGL. لتفعيل ميزات OpenGL 2.0 قمت أيضاً بتعيين "تمكين دعم ARB_occlusion_query على 915/945" إلى نعم في علامة التبويب "Deboguage". مصدر - tuk0z


أوبونتو 10.10 ينبغي تحتوي على برامج التشغيل لـ GMA 3150. يبدو هذا وضعا غريبا بعض الشيء ، حيث يقول موقع إنتل على الإنترنت:

يدعم برنامج Intel Graphics Media Accelerator 3150 OpenGL * 1.5 مع Microsoft * Windows * و OpenGL * 2.0 مع Linux *

أود أن أقترح عليك الإبلاغ عن خطأ ، عن طريق الضغط البديل+F2 والدخول ubuntu-bug xserver-xorg-video-intel. سيؤدي هذا إلى إرفاق معلومات حول إعداد الأجهزة إلى تقرير الخطأ تلقائيًا. بهذه الطريقة سوف يحصل فريق رسومات Ubuntu على مشكلتك ويساعدك على حلها.


2
2018-01-01 09:02



Bug # 696190: تدعم برامج تشغيل Intel لـ GMA 3150 فقط OpenGL 1.4 بدلاً من 2.0 - 8128
نعم هذا هو علة ذكرت ............ يرجى الاشتراك إذا كنت تواجه نفس المشكلة - mahmoudelbadry